4.3.0

Patches

4.3.0.1

Premium Only

  • Fix issue when WP_FAIL2BAN_BLOCK_USERNAME_LOGIN enabled and WP_FAIL2BAN_BLOCKED_USERS not configured.

4.3.0.2

Premium Only

  • Fix issue where some events weren’t logged.

4.3.0.3

Premium Only

  • Fix incorrect total for Event Log.
  • Fix database renumber for Pingbacks.

4.3.0.4

  • Fix plugin event registration.
  • Add colour to “Last 5 Messages” dashboard widget.

4.3.0.5

  • Fix empty username detection for multisite.
  • Fix harmless warning when activating new multisite install.
  • Fix esoteric edge-case where wp-load.php is loaded via a script run from the CLI in a directory with a functions.php file.

4.3.0.6

  • Fix Forbidden error on Posts page for roles below Editor when user enum blocking enabled. [WordPress only]

Upgrade

To take advantage of the new features you will need up update your fail2ban filters; existing filters will continue to work as before. Premium users: Please backup your database before upgrading.